« これはすごい。「パッチョのあのキャラに会いたいパッチョー」 | トップページ | rubyのmemcache-clientはmemcacheのキーにコロン(:)が含まれていると、その左辺をclass名と認識して、自動的にマッピングしてくれる »

2009.11.20

rubyのmemcache-client-1.7.6にキャッシュをdelete(expire)できない不具合

削除できないなぁ。。と思っていたら仕様変更?にともなう不具合なのかな。

これ、本家では直っていないけど、みんな困っていないのかなぁ・・?

修正されているバージョンがgithubで公開されている。

http://github.com/billhorsman/memcache-client/commit/adfcb8115e74b051f7c858e21dc5fcaeb477a52a


しかし、githubとgemの流儀がわからないんだけど、いくらgithubで修正済みのものが公開されているとしても、これをgemでインストールして良いものなの?
その場合、どれをロードすべきなの?
そして、その後のバージョンアップは?

わからないなぁ。。。

となると、パッチを手元の本家のバージョンに適用するのが良いのかな。と思って、そうしてみた。
けど、他のサーバーでgem install ...とか気軽にできなくなるなぁ。

|

« これはすごい。「パッチョのあのキャラに会いたいパッチョー」 | トップページ | rubyのmemcache-clientはmemcacheのキーにコロン(:)が含まれていると、その左辺をclass名と認識して、自動的にマッピングしてくれる »

ruby」カテゴリの記事

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/22269/46813802

この記事へのトラックバック一覧です: rubyのmemcache-client-1.7.6にキャッシュをdelete(expire)できない不具合:

« これはすごい。「パッチョのあのキャラに会いたいパッチョー」 | トップページ | rubyのmemcache-clientはmemcacheのキーにコロン(:)が含まれていると、その左辺をclass名と認識して、自動的にマッピングしてくれる »